sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-perl / Test-MockModule / Test-MockModule-0.110.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_VERSION=0.11
7 DIST_AUTHOR=GFRANKS
8 inherit perl-module
9
10 DESCRIPTION="Override subroutines in a module for unit testing"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Carp
19         dev-perl/SUPER
20         virtual/perl-Scalar-List-Utils
21 "
22 DEPEND="${RDEPEND}
23         >=dev-perl/Module-Build-0.380.0
24         test? ( >=virtual/perl-Test-Simple-0.450.0 )
25 "
26 src_test() {
27         perl_rm_files t/pod_coverage.t t/pod.t
28         perl-module_src_test
29 }