dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Test-CleanNamespaces / Test-CleanNamespaces-0.220.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ETHER
7 DIST_VERSION=0.22
8 inherit perl-module
9
10 DESCRIPTION="Check for uncleaned imports"
11
12 SLOT="0"
13 KEYWORDS="amd64 ~arm arm64 hppa ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test minimal"
15 RESTRICT="!test? ( test )"
16
17 # r:Test::Builder -> Test-Simple
18 # t:Scalar::Util -> Scalar-List-Utils
19 # t:Test::Tester -> ( Ugh )
20 RDEPEND="
21         !minimal? (
22                 dev-perl/Package-Stash-XS
23         )
24         >=virtual/perl-Exporter-5.570.0
25         virtual/perl-File-Spec
26         dev-perl/Module-Runtime
27         >=dev-perl/Package-Stash-0.140.0
28         dev-perl/Sub-Identify
29         virtual/perl-Test-Simple
30 "
31 DEPEND="${RDEPEND}
32         >=virtual/perl-CPAN-Meta-Requirements-2.120.620
33         virtual/perl-ExtUtils-MakeMaker
34         !<dev-perl/Role-Tiny-1.3.0
35         test? (
36                 !minimal? (
37                         >=virtual/perl-CPAN-Meta-2.120.900
38                 )
39                 dev-perl/File-pushd
40                 virtual/perl-Scalar-List-Utils
41                 dev-perl/Sub-Exporter
42                 dev-perl/Test-Deep
43                 dev-perl/Test-Needs
44                 >=virtual/perl-Test-Simple-1.1.10
45                 >=dev-perl/Test-Warnings-0.9.0
46                 virtual/perl-if
47                 dev-perl/namespace-clean
48                 virtual/perl-parent
49         )
50 "