dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / Sys-Virt / Sys-Virt-1.1.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=DANBERR
7 MODULE_VERSION=1.1.2
8 inherit perl-module
9
10 DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
11
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=">=app-emulation/libvirt-${PV}"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig
20         test? (
21                 dev-perl/XML-XPath
22                 virtual/perl-Time-HiRes
23         )"
24 PATCHES=( "${FILESDIR}/no-dot-inc.patch" )
25 SRC_TEST="do"
26
27 src_compile() {
28         MAKEOPTS+=" -j1" perl-module_src_compile
29 }
30
31 src_test() {
32         perl_rm_files "t/010-pod-coverage.t" "t/005-pod.t" "t/015-changes.t"
33         perl-module_src_test
34 }