sys-apps/groff: stable 1.22.4 for hppa, bug #704420
[gentoo.git] / dev-perl / Sub-Quote / Sub-Quote-2.3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=HAARG
7 DIST_VERSION=2.003001
8 inherit perl-module
9
10 DESCRIPTION="efficient generation of subroutines via string eval"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm hppa ~ia64 ppc ~ppc64 ~sparc x86"
13 IUSE="test minimal"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         !<dev-perl/Moo-2.3.0
18         !minimal? (
19                 >=dev-perl/Sub-Name-0.80.0
20         )
21         virtual/perl-Scalar-List-Utils
22 "
23 DEPEND="${RDEPEND}
24         virtual/perl-ExtUtils-MakeMaker
25         test? (
26                 >=dev-perl/Test-Fatal-0.3.0
27                 >=virtual/perl-Test-Simple-0.940.0
28         )
29 "