sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-perl / Sphinx-Search / Sphinx-Search-0.310.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=JJSCHUTZ
7 DIST_VERSION=0.31
8 inherit perl-module
9
10 DESCRIPTION="Perl API client for Sphinx search engine"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Carp
19         dev-perl/Class-Accessor
20         dev-perl/DBI
21         virtual/perl-Data-Dumper
22         virtual/perl-Encode
23         dev-perl/List-MoreUtils
24         dev-perl/File-SearchPath
25         virtual/perl-Scalar-List-Utils
26         virtual/perl-Math-BigInt
27         dev-perl/Path-Class
28         virtual/perl-Socket
29 "
30 DEPEND="${RDEPEND}
31         virtual/perl-ExtUtils-MakeMaker
32         test? (
33                 virtual/perl-Test-Simple
34         )
35 "
36 PERL_RM_FILES=( "t/pod-coverage.t" "t/pod.t" "t/boilerplate.t" )