dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / Sphinx-Config / Sphinx-Config-0.100.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=JJSCHUTZ
7 DIST_VERSION=0.10
8 inherit perl-module
9
10 DESCRIPTION="Sphinx search engine configuration file read/modify/write"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Carp
19         dev-perl/List-MoreUtils
20         virtual/perl-Storable
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? ( virtual/perl-Test-Simple )
25 "
26
27 src_test() {
28         perl_rm_files "t/pod-coverage.t" "t/boilerplate.t" "t/pod.t"
29         perl-module_src_test
30 }