sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-perl / Search-Xapian / Search-Xapian-1.2.25.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=OLLY
7 inherit perl-module toolchain-funcs versionator
8
9 VERSION=$(get_version_component_range 1-3)
10
11 SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
12 DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
13
14 LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
17 IUSE="examples test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-libs/xapian:0/1.2.22
21         !dev-libs/xapian-bindings[perl]"
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? ( dev-perl/Devel-Leak )
25 "
26
27 DIST_TEST=do
28 # parallel fails sometimes...
29
30 myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
31
32 src_install() {
33         perl-module_src_install
34
35         use examples && {
36                 docinto examples
37                 dodoc "${S}"/examples/*
38         }
39 }