dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Redis / Redis-1.991.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DAMS
7 DIST_VERSION=1.991
8 inherit perl-module
9
10 DESCRIPTION="Perl binding for Redis database"
11
12 LICENSE="Artistic-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test minimal"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=dev-perl/IO-Socket-Timeout-0.290.0
20         dev-perl/Try-Tiny
21 "
22 DEPEND="${RDEPEND}
23         >=dev-perl/Module-Build-Tiny-0.39.0
24         test? (
25                 !minimal? (
26                         dev-db/redis
27                 )
28                 virtual/perl-Digest-SHA
29                 virtual/perl-File-Spec
30                 virtual/perl-IO
31                 dev-perl/IO-String
32                 virtual/perl-IPC-Cmd
33                 dev-perl/Test-Deep
34                 dev-perl/Test-Fatal
35                 >=virtual/perl-Test-Simple-0.980.0
36                 dev-perl/Test-SharedFork
37                 >=dev-perl/Test-TCP-1.190.0
38         )
39 "
40
41 DIST_TEST="do"
42
43 src_test() {
44         local badfiles=(
45                 "t/release-distmeta.t"
46                 "t/release-pod-coverage.t"
47         )
48         if use minimal; then
49                 einfo "Disabling Redis Server spawning tests (USE=minimal)"
50                 badfiles+=(
51                         t/01-basic.t
52                         t/02-responses.t
53                         t/03-pubsub.t
54                         t/04-pipeline.t
55                         t/05-nonblock.t
56                         t/06-on-connect.t
57                         t/07-reconnect.t
58                         t/08-unix-socket.t
59                         t/10-tie-list.t
60                         t/11-timeout.t
61                         t/20-tie-hash.t
62                         t/30-scripts.t
63                         t/42-client_cmds.t
64                         t/44-no-unicode-bug.t
65                         t/50-fork_safe.t
66                 )
67         fi
68         perl_rm_files "${badfiles[@]}"
69         # https://github.com/PerlRedis/perl-redis/issues/127#issuecomment-354670681
70         export REDIS_DEBUG=1
71         perl-module_src_test
72 }