dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-perl / Proc-Simple / Proc-Simple-1.320.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MSCHILLI
7 DIST_VERSION=1.32
8 inherit perl-module
9
10 DESCRIPTION="Launch and control background processes"
11
12 SLOT="0"
13 KEYWORDS="amd64 ppc x86"
14 IUSE="test examples"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="virtual/perl-IO"
18 DEPEND="
19         virtual/perl-ExtUtils-MakeMaker
20         test? ( virtual/perl-Test-Simple )
21 "
22
23 src_install() {
24         perl-module_src_install
25         if use examples; then
26                 docompress -x /usr/share/doc/${PF}/examples
27                 docinto examples
28                 dodoc -r eg/*
29         fi
30 }