sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-perl / Perl-Tidy / Perl-Tidy-20171214.0.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=SHANCOCK
7 DIST_VERSION=20171214
8 DIST_EXAMPLES=( "examples/*" )
9 inherit perl-module
10
11 DESCRIPTION="Perl script indenter and beautifier"
12 HOMEPAGE="http://perltidy.sourceforge.net/ https://metacpan.org/release/Perl-Tidy"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE=""
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}
21         virtual/perl-ExtUtils-MakeMaker
22 "
23
24 src_install() {
25         perl-module_src_install
26
27         # Compressing pod is bad because perldoc can't decompress
28         # bzip2 automatically, and `less` can't render perldoc
29         docompress -x /usr/share/doc/${PF}/stylekey.pod
30         docompress -x /usr/share/doc/${PF}/tutorial
31
32         docinto ''
33         dodoc docs/stylekey.pod
34
35         docinto tutorial
36         dodoc docs/tutorial.pod docs/testfile.pl
37 }