dev-perl/Business-ISBN: Bump to version 3.5.0
[gentoo.git] / dev-perl / Perl-PrereqScanner / Perl-PrereqScanner-1.23.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 DIST_AUTHOR=RJBS
6 DIST_VERSION=1.023
7 inherit perl-module
8
9 DESCRIPTION="a tool to scan your Perl code for its prerequisites"
10
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test minimal"
14 RESTRICT="!test? ( test )"
15 # r: File::Find -> perl
16 # r: File::Spec::Functions -> File-Spec
17 # r: FindBin  -> perl
18 # r: List::Util -> Scalar-List-Utils
19 # r: Moose::Role -> Moose
20 # r: Scalar::Util -> Scalar-List-Utils
21 # r: lib, strict, warnings -> perl
22 RDEPEND="
23         >=virtual/perl-CPAN-Meta-Requirements-2.124.0
24         virtual/perl-File-Spec
25         virtual/perl-Getopt-Long
26         dev-perl/Getopt-Long-Descriptive
27         dev-perl/List-MoreUtils
28         virtual/perl-Scalar-List-Utils
29         dev-perl/Module-Path
30         dev-perl/Moose
31         >=dev-perl/PPI-1.215.0
32         dev-perl/Params-Util
33         >=dev-perl/String-RewritePrefix-0.5.0
34         dev-perl/namespace-autoclean
35 "
36 # t: PPI::Document -> PPI
37 DEPEND="${RDEPEND}
38         virtual/perl-ExtUtils-MakeMaker
39         test? (
40                 !minimal? (
41                         >=virtual/perl-CPAN-Meta-2.120.900
42                 )
43                 virtual/perl-File-Temp
44                 >=virtual/perl-Test-Simple-0.960.0
45                 dev-perl/Try-Tiny
46         )
47 "