dev-perl/Class-Default: Fix for '.' in @INC re bug #615116
[gentoo.git] / dev-perl / OOTools / OOTools-2.400.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=SKNPP
7 DIST_VERSION=2.4
8 inherit perl-module
9
10 DESCRIPTION="Pragma to implement lvalue accessors with options"
11 SRC_URI+=" https://dev.gentoo.org/~tove/distfiles/${CATEGORY}/${PN}/${PN}-2.300.0-patch.tar.bz2"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="test"
16
17 DEPEND="
18         dev-perl/Module-Build
19         test? (
20                 dev-perl/CGI
21         )
22 "
23
24 EPATCH_SUFFIX=patch
25 PATCHES=(
26         "${WORKDIR}"/${DIST_NAME:-${PN}}-patch
27 )
28 PERL_RM_FILES=( t/test_pod.t t/test_pod_coverage.t )