dev-libs/leatherman: remove installing vendored boost library
[gentoo.git] / dev-perl / Number-WithError / Number-WithError-1.10.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=SMUELLER
7 DIST_VERSION=1.01
8 inherit perl-module
9
10 DESCRIPTION="Numbers with error propagation and scientific rounding"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         >=virtual/perl-Math-BigInt-1.400.0
18         >=dev-perl/Params-Util-0.100.0
19         >=dev-perl/prefork-1.0.0
20 "
21 DEPEND="${RDEPEND}
22         >=virtual/perl-ExtUtils-MakeMaker-6.420.0
23         test? (
24                 dev-perl/Test-LectroTest
25                 >=virtual/perl-Test-Simple-0.470.0
26         )
27 "
28 PATCHES=(
29         "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
30 )
31 PERL_RM_FILES=(
32         "t/00podcover.t"
33         "t/00pod.t"
34 )