dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Net-Whois-IP / Net-Whois-IP-1.190.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_VERSION=${PV%0.0}
7 DIST_AUTHOR=BSCHMITZ
8 inherit perl-module
9
10 DESCRIPTION="Perl extension for looking up the whois information for ip addresses"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 PERL_RM_FILES=(
16         "test.pl" # gets installed otherwise :(
17 )
18 RDEPEND="
19         dev-perl/Regexp-IPv6
20 "
21 DEPEND="${RDEPEND}
22         virtual/perl-ExtUtils-MakeMaker
23 "
24 src_test() {
25         local MODULES=(
26                 "Net::Whois::IP ${DIST_VERSION}"
27         )
28         local failed=()
29         for dep in "${MODULES[@]}"; do
30                 ebegin "Compile testing ${dep}"
31                         perl -Mblib="${S}" -M"${dep} ()" -e1
32                 eend $? || failed+=( "$dep" )
33         done
34         if [[ ${failed[@]} ]]; then
35                 echo
36                 eerror "One or more modules failed compile:";
37                 for dep in "${failed[@]}"; do
38                         eerror "  ${dep}"
39                 done
40                 die "Failing due to module compilation errors";
41         fi
42         # # All tests defined require networking
43         #  and all fail.
44         # https://rt.cpan.org/Public/Bug/Display.html?id=110961
45         # local my_test_control
46         # my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
47         # if ! has network ${my_test_control} ; then
48         #       perl_rm_files "t/test1.t" "t/testx.t"
49         # fi
50         # perl-module_src_test
51 }