dev-perl: Remove *-fbsd KEYWORDS
[gentoo.git] / dev-perl / Net-SMTP-SSL / Net-SMTP-SSL-1.40.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=RJBS
7 DIST_VERSION=1.04
8 inherit perl-module
9
10 DESCRIPTION="(Deprecated) SSL support for Net::SMTP"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15
16 RDEPEND="
17         virtual/perl-libnet
18         dev-perl/IO-Socket-SSL
19 "
20 DEPEND="${RDEPEND}
21         virtual/perl-ExtUtils-MakeMaker
22         test? ( >=virtual/perl-Test-Simple-0.470.0 )
23 "
24
25 pkg_postinst() {
26         elog "This package is deprecated by upstream as equivalent support for SSL and"
27         elog "STARTTLS is available with Net::SMTP 2.35, found in:"
28         elog "  >=virtual/perl-libnet-1.28 ( >=dev-lang/perl-5.20.0 )"
29         elog "Subsequently, this package is only available for compatibility reasons, and"
30         elog "should be avoided in new code."
31 }