dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Net-IRC / Net-IRC-0.790.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR="APEIRON"
7 MODULE_VERSION=0.79
8 inherit perl-module
9
10 DESCRIPTION="Perl IRC module"
11
12 SLOT="0"
13 LICENSE="Artistic"
14 KEYWORDS="amd64 ~arm ~arm64 ~mips ppc ~ppc64 x86"
15 IUSE=""
16
17 SRC_TEST="do"
18
19 mydoc="TODO"
20
21 src_prepare() {
22         # Remove the stdin and warning input required re deprecated.
23         sed -i \
24                 -e '/or die $warning/d' \
25                 -e '/my $acceptance/,/$acceptance eq $ok/d' \
26                 "${S}"/Makefile.PL || die "sed failed"
27         perl-module_src_prepare
28 }