dev-perl/Net-DNS-Resolver-Mock: keyworded 1.201.710.310 for ppc/ppc64/ia64, bug ...
[gentoo.git] / dev-perl / Net-DNS-Resolver-Mock / Net-DNS-Resolver-Mock-1.201.710.310.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MBRADSHAW
7 DIST_VERSION=1.20171031
8 inherit perl-module
9
10 DESCRIPTION="Mock a DNS Resolver object for testing"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
13 IUSE="test"
14
15 RDEPEND="dev-perl/Net-DNS"
16 DEPEND="${RDEPEND}
17         virtual/perl-ExtUtils-MakeMaker
18         test? (
19                 virtual/perl-Test-Simple
20         )
21 "
22 src_test() {
23         perl_rm_files t/author-*.t
24         perl-module_src_test
25 }