dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Mozilla-PublicSuffix / Mozilla-PublicSuffix-1.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=RSIMOES
7 DIST_VERSION="v${PV}"
8 inherit perl-module
9
10 DESCRIPTION="Get a domain name's public suffix via the Mozilla Public Suffix List"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 PATCHES=(
17         "${FILESDIR}/${PV}-no-dynamic-update.patch"
18 )
19 RDEPEND="
20         virtual/perl-Exporter
21         dev-perl/URI
22 "
23 DEPEND="${RDEPEND}
24         virtual/perl-IO
25         >=dev-perl/Module-Build-0.280.0
26         test? (
27                 virtual/perl-Test-Simple
28                 virtual/perl-File-Spec
29         )
30 "
31 src_test() {
32         perl_rm_files t/author-* t/release-*
33         perl-module_src_test
34 }