dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / MooX-StrictConstructor / MooX-StrictConstructor-0.10.0.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DIST_AUTHOR=HARTZELL
7 DIST_VERSION=0.010
8 inherit perl-module
9
10 DESCRIPTION="Make your Moo-based object constructors blow up on unknown attributes"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         dev-perl/Class-Method-Modifiers
18         >=dev-perl/Moo-1.1.0
19         dev-perl/strictures
20 "
21 BDEPEND="${RDEPEND}
22         virtual/perl-ExtUtils-MakeMaker
23         test? (
24                 virtual/perl-File-Spec
25                 virtual/perl-File-Temp
26                 virtual/perl-IO
27                 dev-perl/Test-Fatal
28                 >=virtual/perl-Test-Simple-0.880.0
29         )
30 "