dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / dev-perl / Monitoring-Plugin / Monitoring-Plugin-0.390.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=NIERLEIN
7 DIST_VERSION=0.39
8 inherit perl-module
9
10 DESCRIPTION="Modules to streamline Nagios, Icinga, Shinken, etc. plugins"
11
12 SLOT="0"
13 KEYWORDS="amd64 hppa sparc x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Carp
19         dev-perl/Class-Accessor
20         dev-perl/Config-Tiny
21         virtual/perl-File-Spec
22         dev-perl/Math-Calc-Units
23         dev-perl/Params-Validate
24 "
25 DEPEND="${RDEPEND}
26         >=virtual/perl-ExtUtils-MakeMaker-6.590.0
27         test? ( >=virtual/perl-Test-Simple-0.620.0 )
28 "
29
30 src_prepare() {
31         sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
32                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
33         perl-module_src_prepare
34 }