727fe2fc681505f364d2c50cf30560258c396bdb
[gentoo.git] / dev-perl / Mock-Config / Mock-Config-0.30.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=RURBAN
7 DIST_VERSION=0.03
8 inherit perl-module
9
10 DESCRIPTION="Temporarily set Config or XSConfig values"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ~ppc64 sparc x86"
13 LICENSE="Artistic-2"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         virtual/perl-ExtUtils-MakeMaker
20         test? (
21                 virtual/perl-Test-Simple
22         )
23 "
24 src_test() {
25         perl_rm_files t/pod-coverage.t t/pod.t t/manifest.t
26         perl-module_src_test
27 }