profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / dev-perl / MaxMind-DB-Common / MaxMind-DB-Common-0.40.1.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DIST_AUTHOR=MAXMIND
7 DIST_VERSION=0.040001
8 inherit perl-module
9
10 DESCRIPTION="Code shared by the MaxMind DB reader and writer modules"
11 LICENSE="Artistic-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Carp
19         dev-perl/Data-Dumper-Concise
20         dev-perl/DateTime
21         virtual/perl-Exporter
22         dev-perl/List-AllUtils
23         virtual/perl-Math-BigInt
24         dev-perl/Moo
25         dev-perl/MooX-StrictConstructor
26         virtual/perl-Scalar-List-Utils
27         dev-perl/Sub-Quote
28         virtual/perl-autodie
29         dev-perl/namespace-autoclean
30 "
31 BDEPEND="${RDEPEND}
32         virtual/perl-ExtUtils-MakeMaker
33         test? (
34                 virtual/perl-File-Spec
35                 >=virtual/perl-Test-Simple-0.960.0
36         )
37 "
38 PERL_RM_FILES=(
39         "t/author-00-compile.t"
40         "t/author-eol.t"
41         "t/author-no-tabs.t"
42         "t/author-pod-spell.t"
43         "t/author-pod-syntax.t"
44         "t/author-test-version.t"
45         "t/release-cpan-changes.t"
46         "t/release-portability.t"
47         "t/release-synopsis.t"
48         "t/release-tidyall.t"
49 )