dev-libs/leatherman: remove installing vendored boost library
[gentoo.git] / dev-perl / Math-Base36 / Math-Base36-0.140.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=BRICAS
7 MODULE_VERSION=0.14
8 inherit perl-module
9
10 DESCRIPTION="Encoding and decoding of base36 strings"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86 ~ppc-aix"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 DEPEND="
18         test? (
19                 dev-perl/Test-Exception
20         )
21 "
22
23 SRC_TEST="do"
24
25 src_prepare() {
26         sed -i -e 's/use inc::Module::Install /use lib q[.];\nuse inc::Module::Install /' Makefile.PL ||
27                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
28         perl-module_src_prepare
29 }
30
31 src_test() {
32         perl_rm_files t/99-pod.t t/98-pod_coverage.t
33         perl-module_src_test
34 }