dev-perl/MARC-Record: Cleanup old version 2.0.6
[gentoo.git] / dev-perl / MCE / MCE-1.826.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MARIOROY
7 DIST_VERSION=1.826
8 inherit perl-module
9
10 DESCRIPTION="Many-Core Engine providing parallel processing capabilities"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc ~x86"
13 IUSE="test +sereal"
14
15 RDEPEND="
16         virtual/perl-Carp
17         virtual/perl-File-Path
18         virtual/perl-Getopt-Long
19         virtual/perl-IO
20         virtual/perl-Scalar-List-Utils
21         virtual/perl-Socket
22         >=virtual/perl-Storable-2.40.0
23         virtual/perl-Time-HiRes
24         sereal? (
25                 >=dev-perl/Sereal-Encoder-3.15.0
26                 >=dev-perl/Sereal-Decoder-3.15.0
27         )
28 "
29 DEPEND="${RDEPEND}
30         virtual/perl-ExtUtils-MakeMaker
31         test? ( virtual/perl-Test-Simple )
32 "