b35e5ffbff8c8a902b1297437f8d4991eb0eb5eb
[gentoo.git] / dev-perl / List-SomeUtils / List-SomeUtils-0.560.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DROLSKY
7 DIST_VERSION=0.56
8 inherit perl-module
9
10 DESCRIPTION="A colletion of List utilities missing from List::Util"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         virtual/perl-Carp
18         virtual/perl-Exporter
19         dev-perl/Module-Implementation
20         >=dev-perl/List-SomeUtils-XS-0.550.0
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         virtual/perl-Text-ParseWords
25         test? (
26                 virtual/perl-File-Spec
27                 dev-perl/Test-LeakTrace
28                 >=virtual/perl-Test-Simple-0.960.0
29         )
30 "