dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / dev-perl / Lab-VXI11 / Lab-VXI11-0.20.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_VERSION=0.02
7 DIST_AUTHOR=AMBA
8 KEYWORDS="~amd64 ~x86"
9 inherit perl-module
10
11 DESCRIPTION="Perl interface to the VXI-11 Test&Measurement backend"
12
13 SLOT="0"
14 IUSE="+libtirpc"
15
16 RDEPEND="
17         !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
18         libtirpc? ( net-libs/libtirpc )
19 "
20 DEPEND="
21         ${RDEPEND}
22         virtual/perl-ExtUtils-MakeMaker
23 "
24
25 src_configure() {
26         if use libtirpc ; then
27                 myconf=(
28                         OPTIMIZE="${CFLAGS} -I/usr/include/tirpc"
29                         LIBS="-ltirpc"
30                 )
31         fi
32         perl-module_src_configure
33 }