dev-libs/tomsfastmath: keyworded 0.13.1 for ia64, bug #725414
[gentoo.git] / dev-perl / JSON-MaybeXS / JSON-MaybeXS-1.3.9.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ETHER
7 DIST_VERSION=1.003009
8 inherit perl-module
9
10 DESCRIPTION="Use Cpanel::JSON::XS with a fallback to JSON::XS and JSON::PP"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test +xs"
15 RESTRICT="!test? ( test )"
16
17 # needs Scalar-Util
18 RDEPEND="
19         virtual/perl-Carp
20         >=virtual/perl-JSON-PP-2.273.0
21         virtual/perl-Scalar-List-Utils
22         xs? (
23                 || (
24                         >=dev-perl/Cpanel-JSON-XS-2.331.0
25                         >=dev-perl/JSON-XS-3.0.0
26                 )
27         )
28 "
29 DEPEND="${RDEPEND}
30         >=virtual/perl-ExtUtils-CBuilder-0.270.0
31         virtual/perl-ExtUtils-MakeMaker
32         virtual/perl-File-Spec
33         virtual/perl-File-Temp
34         test? (
35                 >=virtual/perl-Test-Simple-0.880.0
36         )
37 "