dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / IO-AIO / IO-AIO-4.340.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MLEHMANN
7 DIST_VERSION=4.34
8 inherit perl-module
9
10 DESCRIPTION="Asynchronous Input/Output"
11
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc x86"
14 IUSE=""
15 #RESTRICT="test"
16
17 RDEPEND="dev-perl/common-sense"
18 DEPEND="${RDEPEND}
19         >=dev-perl/Canary-Stability-2001
20         >=virtual/perl-ExtUtils-MakeMaker-6.520.0
21 "
22 src_test() {
23         if [[ "${IO_AIO_SANDBOX_TESTS:-0}" == 0 ]]; then
24                 # Tests trigger stack overflow in sandbox code, see bug 553918
25                 perl_rm_files t/01_stat.t t/02_read.t t/05_readdir.t t/03_errors.t
26                 ewarn "Some tests cannot be run under a sandbox. For details, see:"
27                 ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
28         fi
29         perl-module_src_test
30 }