profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / dev-perl / HTTP-Server-Simple-Mason / HTTP-Server-Simple-Mason-0.140.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=JESSE
7 DIST_VERSION=0.14
8 inherit perl-module
9
10 DESCRIPTION="An abstract baseclass for a standalone mason server"
11
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc x86"
14 IUSE=""
15
16 RDEPEND="
17         dev-perl/Hook-LexWrap
18         dev-perl/URI
19         dev-perl/libwww-perl
20         >=dev-perl/HTML-Mason-1.250.0
21         >=dev-perl/HTTP-Server-Simple-0.40.0
22 "
23 DEPEND="${RDEPEND}"
24
25 # Parallel failures,
26 # https://bugs.gentoo.org/623112
27 DIST_TEST="do"
28 src_prepare() {
29         sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
30                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
31         perl-module_src_prepare
32 }
33 src_test() {
34         perl_rm_files t/02pod.t t/03podcoverage.t
35         perl-module_src_test
36 }