*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / HTTP-Entity-Parser / HTTP-Entity-Parser-0.200.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=KAZEBURO
7 DIST_VERSION=0.20
8 DIST_EXAMPLES=( "eg/*" )
9 inherit perl-module
10
11 DESCRIPTION="PSGI compliant HTTP Entity Parser"
12 SLOT="0"
13 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
14 IUSE="test +xs"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Encode
19         virtual/perl-File-Temp
20         dev-perl/HTTP-MultiPartParser
21         dev-perl/Hash-MultiValue
22         >=dev-perl/JSON-MaybeXS-1.3.7
23         virtual/perl-Module-Load
24         dev-perl/Stream-Buffered
25         >=dev-perl/WWW-Form-UrlEncoded-0.230.0
26         xs? ( >=dev-perl/WWW-Form-UrlEncoded-XS-0.230.0 )
27 "
28 DEPEND="${RDEPEND}
29         >=dev-perl/Module-Build-Tiny-0.35.0
30         test? (
31                 virtual/perl-File-Spec
32                 >=dev-perl/HTTP-Message-6
33                 >=virtual/perl-Test-Simple-0.980.0
34         )
35 "