dev-python/pygments: version bump to 2.1
[gentoo.git] / dev-perl / GraphViz / GraphViz-2.190.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 DIST_A_EXT=tgz
8 DIST_AUTHOR=RSAVAGE
9 DIST_VERSION=2.19
10 inherit perl-module
11
12 DESCRIPTION="GraphViz - Interface to the GraphViz graphing tool"
13
14 LICENSE="Artistic-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18
19 RDEPEND="
20         media-gfx/graphviz
21         virtual/perl-Carp
22         >=virtual/perl-Getopt-Long-2.340.0
23         virtual/perl-IO
24         >=dev-perl/IPC-Run-0.600.0
25         >=dev-perl/libwww-perl-6
26         >=dev-perl/Parse-RecDescent-1.965.1
27         >=virtual/perl-Time-HiRes-1.510.0
28         >=dev-perl/XML-Twig-3.380.0
29         >=dev-perl/XML-XPath-1.130.0
30 "
31 DEPEND="${RDEPEND}
32         >=dev-perl/Module-Build-0.421.100
33         >=dev-perl/File-Which-1.90.0
34         test? (
35                 >=dev-perl/Test-Pod-1.480.0
36                 >=virtual/perl-Test-Simple-1.1.14
37         )
38 "
39
40 src_install() {
41         perl-module_src_install
42
43         insinto /usr/share/doc/${PF}/examples
44         doins "${S}"/examples/*
45 }