dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / GnuPG-Interface / GnuPG-Interface-0.520.0-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ALEXMV
7 DIST_VERSION=0.52
8 inherit perl-module
9
10 DESCRIPTION="Perl module interface to interacting with GnuPG"
11
12 SLOT="0"
13 KEYWORDS="amd64 hppa ppc x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=app-crypt/gnupg-1.2.1-r1
19         virtual/perl-autodie
20         >=virtual/perl-Math-BigInt-1.780.0
21         >=dev-perl/Moo-0.91.11
22         >=dev-perl/MooX-HandlesVia-0.1.4
23         >=dev-perl/MooX-late-0.14.0
24 "
25 DEPEND="${RDEPEND}
26         >=virtual/perl-ExtUtils-MakeMaker-6.360.0
27 "
28
29 PATCHES=(
30         "${FILESDIR}/${P}"-0001-fix-spelling-error-settting-should-be-setting.patch
31         "${FILESDIR}/${P}"-0002-Generalize-the-test-suite.patch
32         "${FILESDIR}/${P}"-0003-subkey-validity-of-an-key-when-we-have-established-n.patch
33         "${FILESDIR}/${P}"-0004-ensure-that-test-covers-all-signatures.patch
34         "${FILESDIR}/${P}"-0005-add-gpg_is_modern-to-test-suite.patch
35         "${FILESDIR}/${P}"-0006-Modern-GnuPG-2.1-reports-more-detail-about-secret-ke.patch
36         "${FILESDIR}/${P}"-0007-test-suite-match-plaintext-output-across-versions-of.patch
37         "${FILESDIR}/${P}"-0008-fix-test_default_key_passphrase-when-passphrase-come.patch
38         "${FILESDIR}/${P}"-0009-clean-up-trailing-whitespace.patch
39         "${FILESDIR}/${P}"-0010-fix-capitalization-of-GnuPG.patch
40         "${FILESDIR}/${P}"-0011-ommand_args-should-be-command_args.patch
41         "${FILESDIR}/${P}"-0012-use-fingerprints-as-inputs-during-tests-to-demonstra.patch
42         "${FILESDIR}/${P}"-0013-move-key-files-to-generic-names.patch
43         "${FILESDIR}/${P}"-0014-fix-spelling-s-convience-convenience.patch
44         "${FILESDIR}/${P}"-0015-added-new-secret-key-with-different-passphrase.patch
45         "${FILESDIR}/${P}"-0016-Test-use-of-gpg-without-explicit-passphrase-agent-pi.patch
46         "${FILESDIR}/${P}"-0017-Kill-any-GnuPG-agent-before-and-after-the-test-suite.patch
47         "${FILESDIR}/${P}"-0018-Use-a-short-temporary-homedir-during-the-test-suite.patch
48         "${FILESDIR}/${P}"-0019-Make-things-work-with-gpg1-assuming-plain-gpg-is-mod.patch
49 )
50
51 DIST_TEST=skip
52 # Nearly all tests succeed with this patchset and GnuPG 2.1 when running outside the
53 # emerge sandbox. However, the agent architecture is not really sandbox-friendly, so...
54 #
55 # Test Summary Report
56 # -------------------
57 # t/decrypt.t              (Wstat: 0 Tests: 6 Failed: 2)
58 #  Failed tests:  5-6
59 # Failed 1/22 test programs. 2/56 subtests failed.
60
61 src_prepare() {
62         sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
63                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
64         perl-module_src_prepare
65 }