dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-perl / Getopt-Long-Descriptive / Getopt-Long-Descriptive-0.103.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=RJBS
7 DIST_VERSION=0.103
8 inherit perl-module
9
10 DESCRIPTION="Getopt::Long with usage text"
11
12 SLOT="0"
13 KEYWORDS="amd64 arm ppc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test minimal"
15 RESTRICT="!test? ( test )"
16
17 CONFLICTS="!<dev-perl/MooseX-Getopt-0.660.0"
18 # File::Basename -> perl
19 # List::Util, Scalar::Util -> perl-Scalar-List-Utils
20 # Sub::Exporter::Util -> Sub-Exporter
21 RDEPEND="${CONFLICTS}
22         virtual/perl-Carp
23         >=virtual/perl-Getopt-Long-2.330.0
24         >=dev-perl/Params-Validate-0.970.0
25         virtual/perl-Scalar-List-Utils
26         >=dev-perl/Sub-Exporter-0.972.0
27 "
28 DEPEND="${RDEPEND}
29         virtual/perl-ExtUtils-MakeMaker
30         test? (
31                 !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
32                 >=dev-perl/CPAN-Meta-Check-0.11.0
33                 virtual/perl-File-Spec
34                 dev-perl/Test-Fatal
35                 >=virtual/perl-Test-Simple-0.960.0
36                 >=dev-perl/Test-Warnings-0.5.0
37         )
38 "