bf38aff0bc8ef695d8ba7f1b3f46ba219c8cfa60
[gentoo.git] / dev-perl / Gentoo-App-Pram / Gentoo-App-Pram-0.200.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MONSIEURP
7 DIST_VERSION=0.200000
8
9 inherit perl-module
10
11 DESCRIPTION="Official tool to merge PRs from the Gentoo Github repository"
12 HOMEPAGE="https://github.com/monsieurp/Gentoo-App-Pram"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm x86"
15 IUSE="test"
16
17 RDEPEND="
18         dev-vcs/git
19         virtual/perl-Encode
20         dev-perl/File-Which
21         dev-perl/Net-SSLeay
22         dev-perl/IO-Socket-SSL
23         virtual/perl-File-Temp
24         virtual/perl-HTTP-Tiny
25         virtual/perl-Getopt-Long
26         virtual/perl-Term-ANSIColor
27         !app-portage/pram"
28
29 DEPEND="
30         ${RDEPEND}
31         dev-perl/Module-Build-Tiny
32         test? (
33                 virtual/perl-Test-Simple
34         )"