dev-perl: Remove *-fbsd KEYWORDS
[gentoo.git] / dev-perl / File-BaseDir / File-BaseDir-0.70.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=KIMRYAN
7 DIST_VERSION=0.07
8 inherit perl-module
9
10 DESCRIPTION="Use the Freedesktop.org base directory specification"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15
16 RDEPEND="
17         virtual/perl-Carp
18         virtual/perl-Exporter
19         virtual/perl-File-Spec
20         dev-perl/IPC-System-Simple
21 "
22 DEPEND="${RDEPEND}
23         dev-perl/Module-Build
24         test? (
25                 dev-perl/File-Which
26                 virtual/perl-File-Temp
27                 virtual/perl-Test-Simple
28         )
29 "
30 DIST_TEST="do" # https://rt.cpan.org/Ticket/Display.html?id=119256
31 src_test() {
32         perl_rm_files t/05_pod_cover.t t/04_pod_ok.t
33         # https://bugs.gentoo.org/624028
34         unset XDG_CONFIG_HOME
35         perl-module_src_test
36 }