sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-perl / Exception-Class / Exception-Class-1.430.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DROLSKY
7 DIST_VERSION=1.43
8 DIST_EXAMPLES=("bench/*")
9 inherit perl-module
10
11 DESCRIPTION="A module that allows you to declare real exception classes in Perl"
12
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=dev-perl/Class-Data-Inheritable-0.20.0
20         >=dev-perl/Devel-StackTrace-2.0.0
21         virtual/perl-Scalar-List-Utils
22 "
23 DEPEND="${RDEPEND}
24         virtual/perl-ExtUtils-MakeMaker
25         test? (
26                 virtual/perl-File-Spec
27                 >=virtual/perl-Test-Simple-0.960.0
28         )
29 "