dev-perl/Exception-Class: Add ~s390 keyword wrt bug #652718
[gentoo.git] / dev-perl / Exception-Class / Exception-Class-1.430.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DROLSKY
7 DIST_VERSION=1.43
8 DIST_EXAMPLES=("bench/*")
9 inherit perl-module
10
11 DESCRIPTION="A module that allows you to declare real exception classes in Perl"
12
13 SLOT="0"
14 KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
15 IUSE="test"
16
17 RDEPEND="
18         >=dev-perl/Class-Data-Inheritable-0.20.0
19         >=dev-perl/Devel-StackTrace-2.0.0
20         virtual/perl-Scalar-List-Utils
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? (
25                 virtual/perl-File-Spec
26                 >=virtual/perl-Test-Simple-0.960.0
27         )
28 "