*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-perl / Error / Error-0.170.250.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=SHLOMIF
7 DIST_VERSION=0.17025
8 inherit perl-module
9
10 DESCRIPTION="Error/exception handling in an OO-ish way"
11
12 LICENSE+=" MIT"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         virtual/perl-Scalar-List-Utils
20 "
21 DEPEND="${RDEPEND}
22         >=dev-perl/Module-Build-0.280.801
23         test? (
24                 virtual/perl-Test-Simple
25         )
26 "
27
28 src_test() {
29         perl_rm_files t/pod-coverage.t t/pod.t t/style-trailing-space.t
30         perl-module_src_test
31 }