dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / dev-perl / Dist-Zilla-Plugin-NameFromDirectory / Dist-Zilla-Plugin-NameFromDirectory-0.40.0.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DIST_AUTHOR=MIYAGAWA
7 DIST_VERSION=0.04
8 inherit perl-module
9
10 DESCRIPTION="Guess distribution name from the current directory"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15 RDEPEND="
16         >=dev-perl/Dist-Zilla-4.300.30
17         >=dev-perl/Path-Tiny-0.53.0
18 "
19 DEPEND="
20         dev-perl/Module-Build-Tiny
21 "
22 BDEPEND="${RDEPEND}
23         >=dev-perl/Module-Build-Tiny-0.34.0
24         test? (
25                 >=virtual/perl-Test-Simple-0.880.0
26         )
27 "
28 PERL_RM_FILES=(
29         "t/author-pod-syntax.t"
30 )