dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / Dist-Zilla-Plugin-CopyFilesFromBuild / Dist-Zilla-Plugin-CopyFilesFromBuild-0.170.880.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DIST_AUTHOR=RTHOMPSON
7 DIST_VERSION=0.170880
8 inherit perl-module
9
10 DESCRIPTION="Copy (or move) specific files after building (for SCM inclusion, etc.)"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15 RDEPEND="
16         dev-perl/Dist-Zilla
17         virtual/perl-IO
18         dev-perl/Moose
19         dev-perl/MooseX-Has-Sugar
20         dev-perl/Path-Tiny
21         >=virtual/perl-Scalar-List-Utils-1.330.0
22         dev-perl/Set-Scalar
23 "
24 BDEPEND="${RDEPEND}
25         virtual/perl-ExtUtils-MakeMaker
26         test? (
27                 virtual/perl-Carp
28                 dev-perl/Dist-Zilla-Plugin-ReadmeAnyFromPod
29                 virtual/perl-File-Spec
30                 dev-perl/Test-Exception
31                 dev-perl/Test-Most
32                 >=virtual/perl-Test-Simple-0.940.0
33                 virtual/perl-autodie
34         )
35 "
36 PERL_RM_FILES=(
37         "t/author-critic.t"
38         "t/author-pod-coverage.t"
39         "t/author-pod-syntax.t"
40         "t/release-has-version.t"
41         "t/release-kwalitee.t"
42         "t/release-portability.t"
43         "t/release-unused-vars.t"
44 )