dev-libs/tomsfastmath: keyworded 0.13.1 for ppc64, bug #725414
[gentoo.git] / dev-perl / DateTime-Format-W3CDTF / DateTime-Format-W3CDTF-0.70.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=GWILLIAMS
7 DIST_VERSION=0.07
8 inherit perl-module
9
10 DESCRIPTION="Parse and format W3CDTF datetime strings"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 ~arm arm64 ppc ppc64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="dev-perl/DateTime"
18 DEPEND="${RDEPEND}
19         >=virtual/perl-ExtUtils-MakeMaker-6.360.0
20         test? (
21                 >=virtual/perl-Test-Simple-0.610.0
22         )
23 "
24 src_prepare() {
25         use test && perl_rm_files t/pod.t t/pod_coverage.t
26         perl-module_src_prepare
27 }