cc8797bb57433bf0616a38cdf24c6b90df331c8d
[gentoo.git] / dev-perl / DateTime-Format-Mail / DateTime-Format-Mail-0.403.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=BOOK
7 DIST_VERSION=0.403
8 inherit perl-module
9
10 DESCRIPTION="Convert between DateTime and RFC2822/822 formats"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 ia64 ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         virtual/perl-Carp
19         >=dev-perl/DateTime-1.40.0
20         dev-perl/Params-Validate
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? (
25                 virtual/perl-File-Spec
26                 virtual/perl-Test-Simple
27         )
28 "
29
30 src_test() {
31         perl_rm_files t/author-*.t t/release-*.t
32         perl-module_src_test
33 }