sys-apps/groff: stable 1.22.4 for hppa, bug #704420
[gentoo.git] / dev-perl / DateTime / DateTime-1.440.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DROLSKY
7 DIST_VERSION=1.44
8 inherit perl-module
9
10 DESCRIPTION="A date and time object"
11
12 LICENSE="Artistic-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 CONFLICTS="
19         !<=dev-perl/DateTime-Format-Mail-0.402.0
20 "
21 RDEPEND="
22         ${CONFLICTS}
23         virtual/perl-Carp
24         >=dev-perl/DateTime-Locale-1.60.0
25         >=dev-perl/DateTime-TimeZone-2.20.0
26         >=dev-perl/Dist-CheckConflicts-0.20.0
27         >=dev-perl/Params-ValidationCompiler-0.130.0
28         virtual/perl-Scalar-List-Utils
29         >=dev-perl/Specio-0.180.0
30         dev-perl/Try-Tiny
31         virtual/perl-XSLoader
32         >=dev-perl/namespace-autoclean-0.190.0
33         virtual/perl-parent
34 "
35 DEPEND="${RDEPEND}
36         virtual/perl-ExtUtils-MakeMaker
37         test? (
38                 virtual/perl-CPAN-Meta-Requirements
39                 >=dev-perl/CPAN-Meta-Check-0.11.0
40                 virtual/perl-File-Spec
41                 virtual/perl-Storable
42                 dev-perl/Test-Fatal
43                 >=virtual/perl-Test-Simple-0.960.0
44                 >=dev-perl/Test-Warnings-0.5.0
45         )
46 "