sys-apps/groff: stable 1.22.4 for hppa, bug #704420
[gentoo.git] / dev-perl / DateTime / DateTime-1.200.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=DROLSKY
7 MODULE_VERSION=1.20
8 inherit perl-module
9
10 DESCRIPTION="A date and time object"
11
12 LICENSE="Artistic-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ppc ppc64 ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         virtual/perl-Carp
20         >=dev-perl/DateTime-Locale-0.410.0
21         >=dev-perl/DateTime-TimeZone-1.740.0
22         >=dev-perl/Params-Validate-0.760.0
23         virtual/perl-Scalar-List-Utils
24         dev-perl/Try-Tiny
25         virtual/perl-XSLoader
26 "
27 DEPEND="${RDEPEND}
28         >=dev-perl/Module-Build-0.280.0
29         test? (
30                 virtual/perl-ExtUtils-MakeMaker
31                 virtual/perl-File-Spec
32                 virtual/perl-Storable
33                 dev-perl/Test-Fatal
34                 >=virtual/perl-Test-Simple-0.880.0
35                 >=dev-perl/Test-Warnings-0.5.0
36         )
37 "
38
39 SRC_TEST="do parallel"