dev-perl/Term-ReadLine-Gnu: add ~ppc64 keyword
[gentoo.git] / dev-perl / DBIx-Class-InflateColumn-IP / DBIx-Class-InflateColumn-IP-0.20.30-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=ILMARI
7 DIST_VERSION=0.02003
8 inherit perl-module
9
10 DESCRIPTION="Auto-create NetAddr::IP objects from columns"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         dev-perl/NetAddr-IP
19         >=dev-perl/DBIx-Class-0.81.70
20 "
21 DEPEND="${RDEPEND}
22         test? ( dev-perl/DBD-SQLite )
23 "
24
25 src_prepare() {
26         sed -i -e 's/use inc::Module::Install /use lib q[.];\nuse inc::Module::Install /' Makefile.PL ||
27                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
28         perl-module_src_prepare
29 }
30
31 src_test() {
32         perl_rm_files t/pod-coverage.t t/pod.t t/style-notabs.t
33         perl-module_src_test
34 }