sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-perl / DBIx-Class-DynamicDefault / DBIx-Class-DynamicDefault-0.40.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=MSTROUT
7 MODULE_VERSION=0.04
8 inherit perl-module
9
10 DESCRIPTION="Automatically set and update fields"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=dev-perl/DBIx-Class-0.81.270
19 "
20 DEPEND="
21         test? ( ${RDEPEND}
22                 virtual/perl-parent
23                 dev-perl/DBICx-TestDatabase
24         )"
25
26 SRC_TEST="do"
27
28 src_prepare() {
29         sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
30                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
31         perl-module_src_prepare
32 }