dev-perl/DBI: mark stable wrt bug #643232
[gentoo.git] / dev-perl / DBI / DBI-1.637.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=TIMB
7 DIST_VERSION=1.637
8 DIST_EXAMPLES=("ex/*")
9 inherit perl-module eutils
10
11 DESCRIPTION="Database independent interface for Perl"
12
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16
17 RDEPEND="
18         >=dev-perl/PlRPC-0.200.0
19         >=virtual/perl-Sys-Syslog-0.170.0
20         virtual/perl-File-Spec
21         !<=dev-perl/SQL-Statement-1.330.0
22 "
23 DEPEND="${RDEPEND}
24         >=virtual/perl-ExtUtils-MakeMaker-6.480.0
25         test? (
26                 >=virtual/perl-Test-Simple-0.900.0
27         )
28 "
29 src_test() {
30         perl_rm_files t/pod-coverage.t t/pod.t
31         perl-module_src_test
32 }