sys-apps/groff: stable 1.22.4 for hppa, bug #704420
[gentoo.git] / dev-perl / Crypt-Cracklib / Crypt-Cracklib-1.700.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DANIEL
7 DIST_VERSION=1.7
8 inherit perl-module
9
10 DESCRIPTION="Perl interface to Alec Muffett's Cracklib"
11
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="sys-libs/cracklib"
18 DEPEND="${RDEPEND}"
19
20 PATCHES=( "${FILESDIR}/${P}-CFLAGS.patch" )
21
22 src_prepare() {
23         use test && perl_rm_files t/pod-coverage.t t/pod.t
24         sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
25                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
26         perl-module_src_prepare
27 }