dev-perl/Term-ReadLine-Gnu: add ~ppc64 keyword
[gentoo.git] / dev-perl / Coro / Coro-6.514.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MLEHMANN
7 DIST_VERSION=6.514
8 DIST_EXAMPLES=( "eg/*" )
9 inherit perl-module
10
11 DESCRIPTION="The only real threads in perl"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="+ev event"
16
17 RDEPEND="
18         >=dev-perl/AnyEvent-5
19         ev? ( >=dev-perl/EV-4.0.0 )
20         event? ( >=dev-perl/Event-0.890.0 )
21         >=dev-perl/Guard-0.500.0
22         virtual/perl-Scalar-List-Utils
23         >=virtual/perl-Storable-2.150.0
24         dev-perl/common-sense
25 "
26 DEPEND="${RDEPEND}
27         dev-perl/Canary-Stability
28         >=virtual/perl-ExtUtils-MakeMaker-6.520.0
29 "
30 PATCHES=(
31         "${FILESDIR}/${PV}-ev-config.patch"
32 )
33 src_configure() {
34         local myopts=()
35         use ev && myopts+=("EV")
36         use event && myopts+=( "Event" )
37         GENTOO_OPTS="${myopts[@]}" perl-module_src_configure
38 }