5967c33598e6ba86f6360cd31da84f02961c9eeb
[gentoo.git] / dev-perl / Convert-ASN1 / Convert-ASN1-0.270.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 MODULE_AUTHOR=GBARR
7 MODULE_VERSION=0.27
8 inherit perl-module
9
10 DESCRIPTION="Standard en/decode of ASN.1 structures"
11
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         >=virtual/perl-ExtUtils-MakeMaker-6.300.0
20         test? (
21                 >=virtual/perl-Math-BigInt-1.997.0
22                 >=virtual/perl-Test-Simple-0.900.0
23         )
24 "
25 PATCHES=(
26         "${FILESDIR}/${P}-perl-526.patch"
27 )
28
29 SRC_TEST=do